# Invoke-IcingaCheckMemory "Invalid input error" when RAM load high

**URL:** <https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458>\
**Category:** Service Monitoring\
**Created:** [August 17, 2023, 9:43am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458 "2023-08-17T09:43:27Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![NiclasE](https://community.icinga.com/letter_avatar_proxy/v4/letter/n/dc4da7/32.png) [@NiclasE](https://community.icinga.com/u/NiclasE)\
**Post date:** [August 17, 2023, 9:43am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/1 "2023-08-17T09:43:27Z")

</div>

I’m using the PS module Invoke-IcingaCheckMemory to check memory load on windows servers. All looks fine until the server actually is under load… then I get this error:  
[UNKNOWN]: Icinga Invalid Input Error was thrown: ConversionUnitMissing

I’ve verified running this manually on the host:  
Invoke-IcingaCheckMemory -Warning 80% -Critical 95%

If the host is not loaded (normal state) the result is:  
[OK] Memory Usage  
| ‘memory::ifw\_memory::used’=1434370000B;5153141600;6119355650;0;6441427000 ‘cpagefilesys::ifw\_pagefile::used’=793772000000000B;;;0;3204448000000000  
0

But if it’s loaded:  
[UNKNOWN]: Icinga Invalid Input Error was thrown: ConversionUnitMissing

Unable to parse input value. You have to add an unit to your input value. Example: “10GB”. Allowed units are: “B, KB, MB, GB, TB, PB, KiB, MiB, GiB, TiB, PiB”.  
Exception calling “WarnOutOfRange” with “1” argument(s): “System error.”  
At C:\Program Files\WindowsPowerShell\Modules\icinga-powershell-plugins\compiled\icinga-powershell-plugins.ifw\_compilation.psm1:2108 char:9

- 

```
    $PageFilePackage.AddCheck(

```

- 

```
    ~~~~~~~~~~~~~~~~~~~~~~~~~~

```

  - CategoryInfo : NotSpecified: (🙂 [], MethodInvocationException
  - FullyQualifiedErrorId : ScriptMethodFlowControlException

[WARNING] Memory Usage [WARNING] Used Memory (84.15% (5.05GiB))  
\_ [WARNING] Used Memory: 84.15% (5.05GiB) is greater than threshold 80% (4.80GiB)  
| ‘memory::ifw\_memory::used’=5420642000B;5153141600;6119355650;0;6441427000  
1

What am I missing or doing wrong? 🙂

---

<div class="post-metadata">

**Author:** ![ExeLeNtCrypt](https://community.icinga.com/letter_avatar_proxy/v4/letter/e/97f17d/32.png) [@ExeLeNtCrypt](https://community.icinga.com/u/ExeLeNtCrypt)\
**Post date:** [August 30, 2023, 7:28am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/2 "2023-08-30T07:28:04Z")

</div>

did you find anything here?

I have a similar Issue. I have 200 hosts that use exactly the same check and it works for them. But now i have a host, that always runs into this error:

 ![Error](https://community.icinga.com/uploads/default/original/2X/e/e27c55939d97d14e986db85197386f0155a1d49d.png)

I tried adjusting the permissions, by using an admin and the local system, none of this helped.

Thanks in advance for any help

---

<div class="post-metadata">

**Author:** ![NiclasE](https://community.icinga.com/letter_avatar_proxy/v4/letter/n/dc4da7/32.png) [@NiclasE](https://community.icinga.com/u/NiclasE)\
**Post date:** [August 30, 2023, 8:37am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/3 "2023-08-30T08:37:17Z")

</div>

No, I haven’t investigated more on this issue actually… I think it has to be something wrong in the code, not permissions as it only happens when the RAM usage is high and not when it’s in “normal” state.

---

<div class="post-metadata">

**Author:** ![ExeLeNtCrypt](https://community.icinga.com/letter_avatar_proxy/v4/letter/e/97f17d/32.png) [@ExeLeNtCrypt](https://community.icinga.com/u/ExeLeNtCrypt)\
**Post date:** [August 30, 2023, 8:40am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/4 "2023-08-30T08:40:58Z")

</div>

but as said for about 200 hosts the check works perfectly fine, with high and with low usage.

Did you try on a different host?

---

<div class="post-metadata">

**Author:** ![NiclasE](https://community.icinga.com/letter_avatar_proxy/v4/letter/n/dc4da7/32.png) [@NiclasE](https://community.icinga.com/u/NiclasE)\
**Post date:** [August 30, 2023, 8:49am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/5 "2023-08-30T08:49:58Z")

</div>

ah sorry, didn’t notice that you written that… hm… ok that is strange indeed… I haven’t tried the manual check on another host actually… I’ll do that and get back.

---

<div class="post-metadata">

**Author:** ![log1c](https://community.icinga.com/user_avatar/community.icinga.com/log1c/32/2071_2.png) [@log1c](https://community.icinga.com/u/log1c)\
**Post date:** [August 30, 2023, 12:04pm UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/6 "2023-08-30T12:04:38Z")

</div>

> [@NiclasE](#):
>
> ConversionUnitMissing

Do the systems with problems have the pagefile enabled and the others dont?

Then maybe this will help: [https://github.com/Icinga/icinga-powershell-plugins/pull/363](https://github.com/Icinga/icinga-powershell-plugins/pull/363)  
At least this fix pops up when searching for `ConversionUnitMissing` in the issues on github.

---

<div class="post-metadata">

**Author:** ![ExeLeNtCrypt](https://community.icinga.com/letter_avatar_proxy/v4/letter/e/97f17d/32.png) [@ExeLeNtCrypt](https://community.icinga.com/u/ExeLeNtCrypt)\
**Post date:** [September 5, 2023, 6:46am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/7 "2023-09-05T06:46:34Z")

</div>

Thank you this was the solution for me.

---

<div class="post-metadata">

**Author:** ![NiclasE](https://community.icinga.com/letter_avatar_proxy/v4/letter/n/dc4da7/32.png) [@NiclasE](https://community.icinga.com/u/NiclasE)\
**Post date:** [September 14, 2023, 10:39am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/8 "2023-09-14T10:39:53Z")

</div>

Now I finally got around testing this… It works. I also saw that the fix should be implemented in the next version of the PS module… One question regarding new versions, how do you upgrade these across all hosts? Is it possible through Icinga somehow or do I need to solve it using other management tools or manually on each host?

---

<div class="post-metadata">

**Author:** ![log1c](https://community.icinga.com/user_avatar/community.icinga.com/log1c/32/2071_2.png) [@log1c](https://community.icinga.com/u/log1c)\
**Post date:** [September 15, 2023, 9:52am UTC](https://community.icinga.com/t/invoke-icingacheckmemory-invalid-input-error-when-ram-load-high/12458/9 "2023-09-15T09:52:41Z")

</div>

Could be done extremely simple via PS Remoting, as it is just a simple command.  
[https://icinga.com/docs/icinga-for-windows/latest/doc/111-Updates-and-Uninstallation/01-Update-Environment/#updating-a-component-to-a-specific-version](https://icinga.com/docs/icinga-for-windows/latest/doc/111-Updates-and-Uninstallation/01-Update-Environment/#updating-a-component-to-a-specific-version)

But no, there is no built-in way with Icinga (afaik) and your best option is some form of automation/cfgmgmt tool.
