Icingaweb2 pages are changed and messy after update Centos 7

Hello everyone,
I have an Icinga2 installed in a CentOS 7

icinga2 --version
icinga2 - The Icinga 2 network monitoring daemon (version: 2.13.2-1)

System information:
Platform: CentOS Linux
Platform version: 7 (Core)
Kernel: Linux
Kernel version: 3.10.0-1160.53.1.el7.x86_64
Architecture: x86_64

php --version
PHP 7.3.33 (cli) (built: Nov 16 2021 11:18:28) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.33, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.3.33, Copyright (c) 1999-2018, by Zend Technologies

I did server update with "yum update -y " and it seems it is updated some files related to icingaweb2 .
I can’t see previous pages. I can login but everything like theme , layout , menu are messy and destroyed, should I setup it from scratch?

I tried in multiple browsers ,all the same problem.


What do you mean destoryed? (A screenshot or any PHP errors may be helpful).

First thought in my mind is PHP was updated, but it’s impossible to know the root problem without an error message.

What version of icingaweb2 is currently installed? Was it affected by the upgrade? yum history info icingaweb2 may be useful.

Hi Ben,
Thanks for response. yum-history and the screenshots is attached .

yum-history.txt (39.3 KB)

The login page (attached) format/layout is changed , I have another machine , I checked it to find css diffracts and it seems so many things is changed .
I can login and I see the page like this:

Only layout is out of order . unfortunately I don’t have any backup/snapshot of this system . Is there a way to restore only web pages , there is a lot of plugins/configurations/integration/api that is done in this server.


Here are modules version installed in this server:
icingacli version
Icinga Web 2 2.9.5
Git Commit 053971c99dc1a4510beb64a888ea695cc14032dc
PHP Version 7.3.29
setup 2.9.5
azure 0.6.3
businessprocess 2.2.0
director 1.8.0
doc 2.9.5
fileshipper 1.2.0
global-dashboards 0.0.0
graphite 1.1.0
incubator 0.6.0
ipl v0.5.0
migrate 2.9.5
monitoring 2.9.5
reactbundle 0.9.0
vspheredb 1.1.0
x509 1.0.0


CSS broken solved by disabling bussiness process module , I am not sure why , but it solved my problem.



1 Like