# Icingaweb2 database error

**URL:** <https://community.icinga.com/t/icingaweb2-database-error/10784>\
**Category:** Icinga Web\
**Created:** [October 9, 2022, 7:09pm UTC](https://community.icinga.com/t/icingaweb2-database-error/10784 "2022-10-09T19:09:14Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![sameer](https://community.icinga.com/letter_avatar_proxy/v4/letter/s/bbce88/32.png) [@sameer](https://community.icinga.com/u/sameer)\
**Post date:** [October 9, 2022, 7:09pm UTC](https://community.icinga.com/t/icingaweb2-database-error/10784/1 "2022-10-09T19:09:14Z")

</div>

After running node wizard with one as master and other as satellite(which should also be second master). I configured pretty much everything but failover doesn’t happen when i shutdown first master…

I am getting this error on icingaweb2 after I changed the database from local to a dedicated server. Also icinga2 database doesn’t show any entry in show tables.

SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘icinga2.icinga\_dbversion’ doesn’t exist, query was: SELECT icinga\_dbversion.version FROM icinga\_dbversion  
SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘icinga2.icinga\_dbversion’ doesn’t exist
