Icingadb-redis instances are taking up lots of RAM

Hi all,

I have an Icinga Infrastructure with a node Master and three Satellites.
I noticed that icingadb-redis takes much RAM on a Satellite.
Every node has 8GB of RAM (master Node Included).
Other nodes are using normally 0.5GB(two Satellites nodes) and 1.5Gb(Master node).

I did tried to increase the RAM for that Satellite Endpoint and now this is the current situation

Is this normal?
Here’s the output for the icingadb-redis instances

ss -anp | grep icingadb
u_str ESTAB  0      0                                               * 1749469                           * 1749474 users:(("icingadb-redis-",pid=606814,fd=2),("icingadb-redis-",pid=606814,fd=1))
tcp   LISTEN 0      511                                         *       users:(("icingadb-redis-",pid=606814,fd=6))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=21))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=15))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=20))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=16))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=13))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=14))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=19))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=7))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=11))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=8))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=10))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=17))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=9))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=18))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=12))
tcp   ESTAB  0      0                                            users:(("icingadb-redis-",pid=606814,fd=22))

[Icinga2 2.11.4, Director 1.10.2]

Any advice?
I’ll be grateful


just cam accross and I am not icingadb and redis expert but it might help. So Redis is a normal memory-cached database, right? So, this could be expected from my point of understanding of Redis. It should utilize a lot of memory. I would say that’s normal, especially because satellites are usually doing the ‘heavy lifting’.

Is this a Windows environment? In the Linux world, you will need to be worried about swap and load… If the system is not swapping, it should normally be okay. Explained in a pragmatic way! :smiley:

Hi @fatslimjoe

thank you! I confirm this satellite endpoint is an Ubuntu machine.
This satellite seems to be greedy in terms of swap and memory usage as you can see


Have you guys ever edited the maxmemory parameter inside redis.config?
I’ve not set it yet.


did you check docu about HW requirements? How big is your enviroment (how much zones, host objects and services total and per zone)?

if there is to much host/service objects per zone it could mean that you should have get more resources …

unfortunatelly cannot give you more advice about redis, maybe someone smarter here could or maybe google is smart enough :slight_smile: