Icinga2 director default zone

We were originally configured with the command files and we are trying to get director setup to work. It appears to have imported all of our commands, endpoints, and zones. Although the endpoints and zones are not editable from the web interface. I have made a default icingaclient template and then when I try to add a host I get this error. It seems to me to not set it to master. lvacicinga2 is our master and devcd.lvac.com is a windows client. Any help would be great I have been trying to figure this out for hours.

[2019-02-18 12:14:11 -0800] critical/config: Error: Validation failed for object 'devcd.lvac.com' of type 'Zone'; Attribute 'zone': Object 'lvacicinga2.lvac.com' of type 'Zone' does not exist.
Location: in /var/lib/icinga2/api/packages/director/a18b3fb8-03ab-4530-be65-c5193b09c15a/zones.d/lvacicinga2.lvac.com/agent_zones.conf: 1:0-1:27
/var/lib/icinga2/api/packages/director/a18b3fb8-03ab-4530-be65-c5193b09c15a/zones.d/lvacicinga2.lvac.com/agent_zones.conf(1): object Zone "devcd.lvac.com" {
/var/lib/icinga2/api/packages/director/a18b3fb8-03ab-4530-be65-c5193b09c15a/zones.d/lvacicinga2.lvac.com/agent_zones.conf(2):     parent = "lvacicinga2.lvac.com"
/var/lib/icinga2/api/packages/director/a18b3fb8-03ab-4530-be65-c5193b09c15a/zones.d/lvacicinga2.lvac.com/agent_zones.conf(3):     endpoints = [ "devcd.lvac.com" ]

[2019-02-18 12:14:11 -0800] critical/config: 1 error

this is my zones.conf on lvacicinga2.
object Endpoint "lvacicinga2.lvac.com" {

object Zone "master" {
	endpoints = [ "lvacicinga2.lvac.com" ]

object Zone "global-templates" {
	global = true

object Zone "director-global" {
	global = true

Also I don’t see master in the zones imported. Everything looks perfect as far as I can tell on the windows computer it actually is showing the parent zone as master.

I really am hoping to fix it. We have about 40 endpoints plus a bunch of other stuff So I really don’t want to rebuild it from scratch if I can help it.

Nevermind. Updated Director to 1.6.1 from 1.0 and it has made drastic difference. There are all kinds of buttons and choices that were not there before. Duhhh.

Interestingly the icingaweb2 is up to date at version 2.6.2-1.stretch. Shouldn’t director module be auto updated with icingaweb2?


Can you share the steps you’ve taken as screenshots from the web interface? Especially the template fields plus the host with the agent settings.

Further, please share the versions involved here (icinga2 --version, Icinga Web 2 - About - Director version).


Well to recap here is what I had and what happened:

  1. We had upgraded from 2.6 to 2.9 icinga2 (we were using the icinga2 node … to configure using the repository.d )
  2. We had upgraded icingaweb2 also probably from 2.6 to 2.9.
  3. icinga-module-director was 1.0 when we upgraded the icingaweb2 the director was not upgraded.
  4. Upgrades where from the directions icinga.org download page for debian add repository.
  5. Hosts, and Zones were showing up at this point in the Directors endpoints and zones from the config files.
  6. But after creating a template in hosts and then trying to add the host based on the template the zone was not defaulting to master and master didn’t appear in the list.
  7. Many frustrating hours later I realized while looking at the github page that the Icinga-module-director was now on 1.6.1 and I was still running 1.0 so I cloned the repository and followed the directions to install it in the /usr/share/icingaweb2/modules/ folder.
  8. Upon restarting things I now had an option in the template to choose “master” in the zones which was not there before.

If I wasn’t clear the problem has been resolved. I now have master in the zone drop down on the templates.



my reply form I had opened yesterday didn’t have your latest replies in it, so my reply came after your resolval :slight_smile:

Additional modules need to be updated by the user, only “core” modules such as monitoring are provided within the Icinga Web 2 package. Keep that in mind for future upgrades.