Icinga director and error autoload.php

Hello

trying to configure icinga director an error occurred with the modules: ipl, reactbundle and incubator.

I download them from git and install them in the path: /usr/share/icingaweb2/modules

I change the names to the folders

image

image

trying to enable them I get this error

image

how can I solve that?

Hi

Please reconfigure the modules like below

#ipl

MODULE_NAME=ipl
MODULE_VERSION=v0.4.0
REPO=“https://github.com/Icinga/icingaweb2-module-${MODULE_NAME}
MODULES_PATH="/usr/share/icingaweb2/modules"
git clone ${REPO} “${MODULES_PATH}/${MODULE_NAME}” --branch “${MODULE_VERSION}”
icingacli module enable “${MODULE_NAME}”

cd /usr/share/icingaweb2/modules/ipl
git checkout ‘v0.4.0’

#************************
#reactbundle

MODULE_NAME=reactbundle
MODULE_VERSION=v0.6.0
REPO=“https://github.com/Icinga/icingaweb2-module-${MODULE_NAME}
MODULES_PATH="/usr/share/icingaweb2/modules"
git clone ${REPO} “${MODULES_PATH}/${MODULE_NAME}” --branch “${MODULE_VERSION}”
icingacli module enable “${MODULE_NAME}”

cd /usr/share/icingaweb2/modules/reactbundle
git checkout ‘v0.7.0’

#******************

#incubator

MODULE_NAME=incubator
MODULE_VERSION=v0.3.0
REPO=“https://github.com/Icinga/icingaweb2-module-${MODULE_NAME}
MODULES_PATH="/usr/share/icingaweb2/modules"
git clone ${REPO} “${MODULES_PATH}/${MODULE_NAME}” --branch “${MODULE_VERSION}”
icingacli module enable “${MODULE_NAME}”

cd /usr/share/icingaweb2/modules/incubator

git checkout ‘v0.5.0’

Regards

I had to use php composer.phar install to search for missing php files, now the modules are installed and enabled, but they don’t work

in the browser it puts me this route
http://192.168.1.81/icingaweb2/director/phperror/dependencies

the path on the server is
/usr/share/icingaweb2/modules/director/application/views/scripts/phperror#

inside phperror there are two files, dependencies.phtml and error.phtml

What can be?

Regards

Hi @Gonza

You should try to delete the modules are already installed and reinstall it again

please share the output while trying to enable the module

icingacli module enable modulname

For some reason it was not running git checkout correctly

Now it works correctly

Thank you