Icinga checks with no certificate and connection timeout errors

Hi all,

How can i check with --no–ssl-certificate on certain plugins, if I donot want to check for ssl certificates.
Also when i check esxi hardware i have the below error. any suggestions would be appreciated.

UNKNOWN: ‘Connection to timed out. (connect timeout=9.99)’

that is check dependent. If your check has that feature you can use it, if if doesn’t you could implement it.

I am using check_esxi_hardware from nagios plugin. I have this issues.
File “/usr/local/lib/python2.7/dist-packages/pywbem/_cim_http.py”, line 494, in wbem_request
timeout=(HTTP_CONNECT_TIMEOUT, conn.timeout))

Is the CIM-Server enabled on the ESXI?

Maybe you need to fix the cim server too:

I have SSL enabled, and as per my guess somehow its redirecting to https, not sure if there is a way to ignore ssl with icinga
Enabled: true
Enabled Running SSLProtocols: tlsv1, tlsv1.1, tlsv1.2
Enabled SSLProtocols: