Icinga 2 Web NCPA Service Check Output not updating

i ran into a strange issue. I’m using the NCPA plugin for windows service checks which is perfectly working fine.
Now I’m trying to add another Windows service “Citrix.AppLayering.Agent” to be checked on a host “issuedHost” which already has some NCPA service checks on it (BNPXE, BNTFTP, soapserver, StreamService, PVSTSB).

The service to be checked (Citrix.AppLayering.Agent) is added directly to the host variable “services_ctx” which will be read by the “ncpa_services_ctx” service.

But somehow this additional service check is not displaying the requested service “Citrix.AppLayering.Agent” in the Plugin Output even after restarting the icinga service.

The windows service variable entry in even read in the icinga2 web …

Here is the configuration:

object Host "issuedHost" {
  check_command = "hostalive"
  address = ""
  zone = "ac-citrix-zone"
  vars.zone = "ac-citrix-zone"
  vars.ncpa = "citrix"
  vars.os = "Win"
  vars.ctx_drives = [ "C", "G" ]
  vars.nics = [ "Ethernet1" ]
  vars.services_ctx = "service=BNPXE,service=StreamService,service=soapserver,service=BNTFTP,service=PVSTSB,service=Citrix.AppLayering.Agent"
  vars.warn = "80"
  vars.crit = "85"

apply Service "ncpa_services_ctx" {
  check_command = "check_citrix_ncpa"
  vars.remote_ncpa_query = "$host.vars.services_ctx$,status=running"
  vars.remote_ncpa_metric = "services"
  assign where host.vars.ncpa == "citrix" && host.vars.services_ctx
  command_endpoint = "otn-icinga-sat-citrix.mon.infra.domain.com"

#check if -q query is needed
object CheckCommand "check_citrix_ncpa" {
  import "plugin-check-command"
  timeout = 180
  command = [
    PluginDir + "/check_ncpa.py",
    "-H", "$address$",
    "-t", api_token,
    "-M", "$remote_ncpa_metric$",
   "-q", "$remote_ncpa_query$",
#   "-v", "-v",
    "--timeout", "180"

Is this correct? Shouldn’t it be

    vars.services_ctx = "service=BNPXE,service=StreamService,service=soapserver,service=BNTFTP,service=PVSTSB,service=Citrix.AppLayering.Agent"

It was a copy and paste mistake to this forum. I corrected it.
So the host config is:

vars.services_ctx = "service=BNPXE,service=StreamService,service=soapserver,service=BNTFTP,service=PVSTSB,service=Citrix.AppLayering.Agent"

That’s the return of an active check to this windows service via console:

root@icinga2:/etc/icinga2/zones.d/ac-citrix-zone>>sudo /usr/lib64/nagios/plugins/check_ncpa.py -H -t <TOKEN> -M services -q service=Citrix.AppLayering.Agent,status=
Last login: Tue May  4 12:45:01 CEST 2021 on cron
OK: Citrix.AppLayering.Agent is running

The issue has been solved by multiple reloading the master and the satellite services. At the end I even rebooted the master server. That might have been the solution…