Host- or Servicegroup define didn't work (in director or manually)

Hello everybody.

I have the following strange behavior:
I define a host group in the Director and fill it with apply ( = * XY *). The “Choices” preview displays hosts matching the selection.
After successfully deploying, no hostgroups are displayed in icingaweb2.
Same thing if define only on cmd under conf.d/groups.conf (groups.conf included in icinga2.conf).

My system data:
Icinga2 2.11.0-1
Icingaweb2 2.7.1
Director master

Thanks for your support!


please do not use the master from the director repository as it is the development branch and breaks often.
You can find the releases here

Thanks for the hint, but since I tested all the previous ones with the same result, I wanted to test the master.

could you post the rendered config from the director? maybe there is a mistake somewhere in the apply rule

Hello Kevin.
Thx for your reply.
Here the rendered hostgroups.conf ( under /var/lib/icinga2/api/zones/director-global/director ).

object HostGroup “AlleLinuxServer” {
display_name = “Alle Linux Server”
assign where match(“LX”,

Before and after the LX is still a * (will not be displayed here)

it does look right. do you have any example hosts that should match this.
For example my apply rules look like this:

object HostGroup "Ubuntu 16.04 LTS" {
    display_name = "Ubuntu 16.04 LTS"
    assign where host.vars.Betriebssystem == "ubuntu_16.04_lts"

Here my definition in director


Last you can see that some Servers match.
But in Icingaweb2 i couldn’t see any groups

Hello everybody.
I can say after some tests that it is probably a problem of icingaweb2. Because the groups are available and work as intended. In Nagvis the groups are displayed and functional.

The problem seems to be solved.
After a major upgrade of the versions to
icinga2: r2.11.2-1
icingaweb2: 2.7.3
director: 1.6.2
the host groups can also be seen in icingaweb2.
(By the way, the services were not visible, as I have stated).

Unfortunately, it took a while because I have no internet access at the customer, so I had to set up an offline apt-mirror on a USB disk. This content first had to be scanned for viruses and released before I could use it.

Unfortunately, the official Ubuntu Mirror has generated some virus alerts, so I had to try several mirrors (Netcologne has worked in the end). All this took a few weeks because the customer’s workflows take a few days.

Thanks and Greetings