Host check_command execution on satellite instead of master

I installed Icinga2 on a brand new Windows host and I connected it to the master as satellite.

The master cannot reach and connect to the satellite because this is into a natted network, but the satellite can connect to the master to things works.

But host is DOWN everytime because the Check Source parameter for the host check command is the master and not the satellite endpoint.

I am able to setup the command_endpoint variable for services but how I can setup it on host check so that it can ping itself and send result to the master?

Thank you!

Hi all,
do you have any answer for me?
Could you help me to understand where I’m wrong, please?
Thank you!

Hello @d83!

Have you tried setting command_endpoint on the Host the same way as on the Services?