Grafana 1.4.2 and PHP 8.2.7

hello Team,

Do we have someone who is using grafana module1.4.2 with PHP 8.2.7 and Icinga IDO ?
It looks like there’s a compatibility problem that’s causing the lack of graphana graph in Icinga web.

`Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$permission is deprecated in usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 61

Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$object is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 283

Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$dashboard is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 180

Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$dashboarduid is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 181

Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$panelId is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 182

Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$orgId is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 183

Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$customVars is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 184

Deprecated: http_build_query(): Passing null to parameter #2 ($numeric_prefix) of type string is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/Helpers/Timeranges.php on line 95

Deprecated: Creation of dynamic property Icinga\Module\Grafana\ProvidedHook\Grapher::$pngUrl is deprecated in /usr/share/icingaweb2/modules/grafana/library/Grafana/ProvidedHook/Grapher.php on line 228
`
Debian GNU/Linux 12 (bookworm)
Linux 6.1.0-17-amd64
PHP 8.2.7 (cli) (built: Jun 9 2023 19:37:27) (NTS)
grafana module 1.4.2
Icinga Web 2 Version 2.12.1
IDO Database (DB IDO) using Postgres 15

The author of the grafana module dropped the support for ido a log time ago.

New features and php8 support is covered in 2.0 and higher which had all of the ido code removed.

Is this an official statement? What will happen to those people with Icinga IDO with Grafana 1.4.2 in a situation where they were forced to move to PHP 8.2.

Migration to Icinga DB is the only solution and Netways will not support the Grafana module in such circumstances?

grafana is a community module.

Every community developer has the right to decide to stop providing support for his modules or any integration and any user has the possibility to fork the project and fix things that are not working.

and here is the statement from the community developer: