Downgrade from 2.10.0 to 2.9.2

i have the following problem when i updated the icinga2 from 2.9.2 to 2.10.0 :

  • CURL ERROR: Operation timed out after 3001 milliseconds with 0 out of 0 bytes received (RestApiClient.php:177).

Due to this error, i want to downgrade back to 2.9.2, but i have the following issue:

yum downgrade icinga2-2.9.2-1.el7.icinga.x86_64.rpm icinga2-bin-2.9.2-1.el7.icinga.x86_64.rpm icinga2-common-2.9.2-1.el7.icinga.x86_64.rpm icinga2-ido-mysql-2.9.2-1.el7.icinga.x86_64.rpm icinga2-libs-2.9.2-1.el7.icinga.x86_64.rpm

–> Processing Dependency: icinga2-libs = 2.9.2-1.el7.icinga for package: icinga2-bin-2.9.2-1.el7.icinga.x86_64
Package icinga2-libs-2.9.2-1.el7.icinga.x86_64 is obsoleted by icinga2-bin-2.10.0-1.el7.icinga.x86_64 which is already installed

Have anyone any idea how to continue the downgrade in this situation ?

Thank you,


With Icinga 2.10 there were some changes in in which packages Icinga is split for installation. The problem is that 2.9 had the package icinga2-libs as dependency which is no longer needed (and no longer available) with Icinga 2.10.

You know, there is a version 2.10.3 which should fix some of the problems with this. 2.11 brings a lot of rewritten code in the network stack and should fix the rest of the problems.

Did you try upgrading to 2.10.3?

1 Like

Hi Thomas,

We tried first to update at 2.10.3 and the problem “curl time out…” persisted.
We made also an “downgrade” to 2.9.2 but as you said due to the packages changes I used yum erase+icinga2 installed packages and after we reinstalled 2.9 version.
Now another issue is still present and no idea what is wrong: the icinga2 service is up and running on the host, the deploy is working but in the GUI “Backend icinga is not running” :disappointed_relieved:
Can you give us any suggestion?

Hi Alin,

Could you please try adding the following line to /etc/icinga2/features-available/ido-mysql.conf:

library "db_ido_mysql"

Just above this line:

object IdoMysqlConnection "ido-mysql" {

We had a change in the configuration file and during your downgrade the file should have been left untouched so the change was not reverted.

1 Like

Problem solved with the credentials, localhost and specific DB in the ido-mysql.conf.
user = “…”
password = “…”
host = “localhost”
database = “db_name”
Thanks a lot!

1 Like

Could you please tick off the checkbox for solution on the post that has the solution to mark the topic solved. This way you show all users that they don’t have to read through the topic just to find that you don’t need no more help.

Thanks in advance.