Curl error in director setup

I run the kickstart wizard in director and I get this message:

CURL ERROR: Failed to connect to 10.10.10.250 port 5665: Connection refused (RestApiClient.php:143)

Endpoint name is my FQDN
Host is the IP
Port 5665
API user root
Password “mysecureapipass”

Any ideas?

Is Icinga 2 running on that IP address and has the REST API enabled, likewise api setup was run before? If so, are there any firewalls in the middle which could prevent access?

Cheers,
Michael

Yes icinga 2 is running on the IP and I did run api setup to generate the user root and password. No firewalls involved.

netstat -tulpen | grep 5665 shows that Icinga2 is listening on that port?
Did you restart/reload icinga2 after api setup?

Ye I reloded it, and I already checked if its listening.

Then i suggest to enable debug log :slight_smile:

A manual call via curl on the CLI works?

curl -k -s -u root:mysecureapipass 'https://10.10.10.250:5665/v1'