API missing "handled" attribute

i had api calls to get service information but recently they’re not returning the “handled” attribute:

curl -k -s -u “$APIUSR:$APIPWD” -H ‘Accept: application/json’ -H ‘X-HTTP-Method-Override: GET’ -X POST ‘https://localhost:5665/v1/objects/services’ -d ‘{ “filter”: “host.name=="MyHostName"”,“joins”: [“host.address”, “host.vars”, “host.state”], “attrs”: [“name”, “downtime_depth”, “display_name”, “acknowledgement”,“handled”], “pretty”: true}’
“error”: 400.0,
“status”: “Invalid field specified: handled”

i was using that as as reference in case the host was down. it worked fine a month ago and it’s running fine in a different lab environment. what could have happened? but more importantly - how to fix it?

I tried it out and it works. is there something messed up with your quotation?
I use icinga 2.13.6

curl -k -s -u "$APIUSR:$APIPWD" -H 'Accept: application/json' -H 'X-HTTP-Method-Override: GET' -X POST 'https://localhost:5665/v1/objects/services' -d '{ "filter": "host.name==\"MyHostName\"","joins": ["host.address", "host.vars", "host.state"], "attrs": ["name", "downtime_depth", "display_name", "acknowledgement","handled"], "pretty": true}'

so after digging into this a little bit more it’s a version thing - the ones where it did not have “handled” are running r2.10.5-1; the ones where it does have it are using r2.11.2-1.

i did an upgrade on one that was missing and it’s there afterwards. marking this as answered.

looks like i need to do work on upgrading the rest of them for consistency.