AD/LDAP Administrator Account "No Dashlets Available"

  • Icinga Web 2 version
  • Used modules: Monitoring Module, Version: 2.8.2
  • Web browser used: Google Chrome
  • Icinga 2 version used: icinga2 - The Icinga 2 network monitoring daemon (version: 2.12.3)
  • PHP version used: rh-php73
  • Server operating system and version: CentOS 7, Kernel version: 3.10.0-1160.11.1.el7.x86_64

Description: I have just installed icinga2 and icingaweb2. I am using LDAP/AD authentication, and I chose an AD user to be the administrator account. When I login using the user, it says " Welcome to Icinga Web! Currently there is no dashlet available. Please contact the administrator." This is the Administrator account and I am at a loss. When I sign in, I have to sign in with the username being AD\user, specifying my domain. I tried the solution from Config menu and others missing - Icinga Web 2 - Monitoring Portal but it did not work. Please help so I can begin using icinga2 for monitoring, thank you!

Current LDAP Settings:


filter = "(&(objectCategory=Person)(sAMAccountName=*)(!(UserAccountControl:1.2.840.113556.1.4.803:=2))(memberOf:1.2.840.113556.1.4.1941:=cn=icinga2-users,ou=domainusers,dc=ad,dc=ursa,dc=com))"
backend = "msldap"
base_dn = "DC=ad,DC=ursa,DC=com"
domain = "AD"
resource = "icingaweb_ldap"


backend = "msldap"
resource = "icingaweb_ldap"
user_backend = "icingaweb2"


users = "rj"
permissions = "*"


show_stacktraces = "1"
show_application_state_messages = "1"
config_backend = "ini"

log = "syslog"
level = "ERROR"
application = "icingaweb2"
facility = "user"


type = "ldap"
hostname = ""
port = "389"
encryption = "none"
root_dn = "CN=icinga2,OU=ServiceAccounts,DC=dc,DC=<domain>,DC=com"
bind_dn = ""
bind_pw = "password"
timeout = "5"

type = "db"
db = "mysql"
host = ""
port = "3306"
dbname = "icingaweb2"
username = "icinga"
password = "password"
charset = ""
use_ssl = "0"

Your are logged in as rj@AD but assigned the rights to rj

1 Like

Oh thank you! I was originally messing up by putting but in roles.ini I changed it to rj@AD and when signing in, it worked perfectly. Thanks nexo! For future people with this issue, here it my roles.ini. Now it is working!!!

users = "rj@AD"
permissions = "*"
1 Like