Account validation for icinga check

Hello Community
I have a huge problem since weeks and it seems like i can’t find any solution. I have a few ncpa checks running on my icinga. For example ncpa-uptime, ncpa-ram, ncpa-cpuload and more but somehow now icinga has problems with running a few of them. The weird part is that some still work but others not even they running on the same host. I am checking uptime and cpu load on one host but just the uptime check fails. Which doesnt make sense because the ncpa software is for both values. The only error message i get are the following:


what could the account validation come from? Does anyone ever had the same problem?
I was looking for the pam_lastlog but couldnt find anything? I am so lost I dont even know where i could look for solving this issue. When i run the check manually on the icinga VM it works completely fine and is giving me the right value back.

I hope anyone can help me thank you in advance

Does it work, if you use the icinga user to execute the check? (might be called nagios if you’re on Debian or related.)

okay I can’t even log in into icinga user

maybe thats the problem

since I tried to log in to my icinga user it suddenly works. Even I still can’t log in that user ?!

But I have some other lines now when i run the command

systemctl status icinga2.service -l

check the following lines:

Not being able to login as the icinga user is ok, it means the system ist configured to not let the user login, which is not necessary for a system user anyway.
You can use the sudo -u icinga as a prefix for the command to run it as the icinga user.

On a side note: Why are you using ncpa?

I need information like:

  • cpu load
  • ram
  • network sent and received
  • services if they running or not
  • uptime
  • rootdisk usage

and the only checks I can request all of them is ncpa. Or do you know a different one? That would be amazing because again it worked completely fine and now I get an error since yesterdey which says

An error occurred:<urlopen error [Errno 111] Connection refused>

Thank you for your help already

Since you are on a Linux system, transport could be achieved by installing an Icinga2 Agent (normal Icinga2 which reports to another instance) oder via SSH (the is a plugin for that called check_by_ssh).
In any case you there are plugins on the target machine necessary, which for most cases can be solved by installing a package called monitoring-plugins or something like that.
It contains many check-plugins, which should achieve most of your goals.

Specific: When and where does this new error occur?